Shared Nothing Live Migration fails when you try to migrate a virtual machine to a destination server in Windows Server 2012

Koskee seuraavia: Windows Server 2012 DatacenterWindows Server 2012 DatacenterWindows Server 2012 Standard

Symptoms


Consider the following scenario:
  • You install the Hyper-V role on a source server and destination server that are running Windows Server 2012.
  • You create a virtual machine (vm1) on the source server.
  • You create two virtual hard disk (VHD) files for the virtual machine. One of the VHD files is larger than drive C on the destination server. For example, you create a 1 gigabyte (GB) VHD file and a 50 GB VHD file, and drive C is smaller than 50 GB.
  • You try to perform a Shared Nothing Live Migration to migrate the virtual machine to the destination server. More specifically, you try to migrate the VHD files as follows:
    • You try to migrate the smaller VHD file to the network share that maps to local drive C. Drive C has limited available space. For example, the available space on drive C is 10 GB.
    • You try to migrate the larger VHD file to the network share that maps to local drive D. Drive D has lots of available space. For example, the available space on drive D is 100 GB.
In this scenario, the migration operation fails, and you receive the following error message:
Migration did not succeed. Not enough disk space at \\destination server\share$.

Cause


This issue occurs because the system checks for available space for the VHD files on only one drive on the destination server. However, the expected behavior is that the system checks for available space on each destination drive.

Resolution


This hotfix is also available at Microsoft Update Catalog

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates