Deployment of a VMware VDP appliance fails on NFS shares on a Windows Storage Server 2008 R2 or Windows Storage Server 2012 server

Symptoms

You deploy a VMware vSphere Data Protection (VDP) appliance on a server that is running Windows Storage Server 2008 R2 or Windows Storage Server 2012. When the deployment accesses the Network File System (NFS) shares on the server, the deployment fails, and you receive the following error message:

Error writing to disk.
Additionally, messages that resemble the following are logged to the "/var/log/vmkernel.log" file during the failure:

# tail –f /var/log/vmkernel.log
2013-03-15T09:30:03.820Z cpu2:9466)BC: 3115: Blocking due to no free buffers. nDirty = 995 nWaiters = 1
2013-03-15T09:30:03.940Z cpu2:9466)BC: 3115: Blocking due to no free buffers. nDirty = 988 nWaiters = 1
2013-03-15T09:30:04.110Z cpu2:9466)BC: 3115: Blocking due to no free buffers. nDirty = 988 nWaiters = 1
2013-03-15T09:30:04.220Z cpu2:9466)BC: 3115: Blocking due to no free buffers. nDirty = 982 nWaiters = 1
2013-03-15T09:30:04.400Z cpu2:9466)BC: 3115: Blocking due to no free buffers. nDirty = 988 nWaiters = 1
2013-03-15T09:30:04.520Z cpu2:9466)BC: 3115: Blocking due to no free buffers. nDirty = 920 nWaiters = 1
2013-03-15T09:31:34.300Z cpu22:9466)BC: 3115: Blocking due to no free buffers. n Dirty = 905 nWaiters = 1
2013-03-15T09:33:07.710Z cpu18:9466)BC: 3115: Blocking due to no free buffers. nDirty = 975 nWaiters = 1
2013-03-15T09:34:45.030Z cpu8:9466)BC: 3115: Blocking due to no free buffers. nDirty = 970 nWaiters = 1
2013-03-15T09:35:17.139Z cpu22:10713)WARNING: UserLinux: 1331: unsupported: (void)
2013-03-15T09:36:16.959Z cpu4:9466)BC: 3115: Blocking due to no free buffers. nDirty = 961 nWaiters = 1
2013-03-15T09:38:30.167Z cpu2:9466)BC: 3115: Blocking due to no free buffers. nDirty = 977 nWaitrs = 1
2013-03-15T09:40:18.908Z cpu0:9466)BC: 3115: Blocking due to no free buffers. nDirty = 977 nWaitrs = 1
2013-03-15T09:42:04.068Z cpu0:8221)NFSLock: 610: Stop accessing fd 0x41000ad83078 3
2013-03-15T09:42:11.082Z cpu2:8194)StorageApdHandler: 248: APD Timer started for ident [e22d08a3-f45c4254]
2013-03-15T09:42:11.082Z cpu2:8194)StorageApdHandler: 395: Device or filesystem with identifier [e22d08a3-f45c4254] has entered the All Paths Down state.
2013-03-15T09:42:11.082Z cpu2:8194)StorageApdHandler: 846: APD Start for ident [e22d08a3-f45c4254]!
2013-03-15T09:43:03.972Z cpu2:8194)NFSLock: 570: Start accessing fd 0x41000ad83078 again
Note After the failure occurs and the vSphere client is updated, the NFS data store comes back online.

Cause

This problem occurs specifically at 99 percent of progress during the VDP deployment. When the second disk is about to be deployed, the NFS data store becomes inaccessible to an ESX host, and the deployment fails with the error message "Error writing to disk." VMware backups to a network access server (NAS) cannot finish when the NFS server cannot set file sparse on the files that are created by the ESX client.

As soon as the failure is logged to the Vmkernel.log file, you receive the "Error writing to disk" error message.

Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1) or Windows Server 2012.

For information about how to obtain a Windows Server 2008 R2 service pack, see Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2 .

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Additional file information

References

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
Properties

Article ID: 2846602 - Last Review: Aug 16, 2013 - Revision: 1

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