Internet Explorer 10 security settings are silently applied to client computers when you use GPMC to view the Group Policy Preferences settings in Windows

Applies to: Windows 8Windows 8 EnterpriseWindows 8 Pro

Symptoms


Consider the following scenario:
  • You have Group Policy Preferences settings for Internet Explorer 10 configured on a computer that is running Windows 8, Windows Server 2012, Windows 8.1 or Windows Server 2012 R2. 
  • You use the Group Policy Management Console (GPMC) to view the settings under the Security tab.
  • In the New Internet Explorer 10 Properties dialog box, you click another tab, or you click OK.
In this scenario, the current default settings under the Security tab are silently written to the Internetsettings.xml file, and then the file is delivered to client computers. Therefore, unintended settings are applied to client computers.

Notes
  • When this issue occurs, there is no visual indication displayed to remind you that the related settings under the active tab are applied to client computers after you click OK.
  • Under the other tabs in the New Internet Explorer 10 Properties dialog box, there is a green circle icon or a red-dashed circle icon next to every configuration option. The green circle icon indicates that the setting of the option will be noted, captured in the Group Policy Object (GPO), and then applied to client computers. The red-dashed circle icon indicates that the setting of the option will be ignored.

Cause


This issue occurs because the green circle icon and red-dashed circle icon functionality is missing under the Security tab in Windows 8 and in Windows Server 2012. This issue occurs when you try to create or edit an Internet Explorer 10 Group Policy Preferences setting in GPMC.

Resolution


Windows 8.1 and Windows Server 2012 R2 update information

To resolve this issue in Windows 8.1 and Windows Server 2012 R2, install update rollup 2903939. For more information about how to obtain this update rollup package, click the following article number to go to the article in the Microsoft Knowledge Base:
2903939 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: December 2013

Windows 8 and Windows Server 2012 hotfix information

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012, or Windows 8 that has the Remote Server Administration Tools for Windows 8 installed.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Workaround


To work around the issue, configure the Internetsettings.xml file manually to enable the protected mode. For more information about how to enable the protected mode, click the following article number to view the article in the Microsoft Knowledge Base:
2733083 No status is displayed on the Security tab for some Group Policy Preferences settings for Internet Explorer 10

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates