Possible Outlook hang if the iManage FileSite add-in is enabled

Applies to: Microsoft Outlook 2010

Symptoms


When using Microsoft Outlook 2010 with the iManage FileSite add-in for Microsoft Outlook installed, Microsoft Support teams have seen issues where Microsoft Outlook 2010 may hang or stop responding.

Note The use of the iManage FileSite add-in for Microsoft Outlook does not necessarily mean you will see this symptom. And, there are definitely other causes for Outlook to hang or stop responding. This article is merely intended to help you identify possible causes of this symptom when using Outlook.

Cause


This problem may be caused by an incompatibility between the iManage add-in and Microsoft Outlook 2010 in some circumstances.

A hang dump analysis performed by Microsoft support has shown the cause to be the imanage.dll.


Resolution


If you are experiencing a hang in Outlook 2010 and you have the FileSite add-in installed, you can use the following steps to temporarily disable the iManage FileSite add-in. If the hanging problem in Outlook is eliminated, we recommend you contact Autonomy, the vendor of the iManage FileSite add-in, to inquire about an updated version of the add-in.

Important
Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.
  1. Exit Microsoft Outlook, if running.
  2. Start registry editor. To do this, use one of the following procedures, as appropriate for your version of Windows.

    Windows 10, Windows 8.1 and Windows 8: Press Windows key + R. Type regedit.exe and then click OK.

    Windows 7: Click Start, type regedit.exe in the search box, and then press Enter.
  3. Locate and select the following registry key, based on the bitness of your Office installation and Windows. 
    • 32-bit Office and 32-bit Windows or 64-bit Office and 64-bit Windows:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\imFileSite.Connect

    • 32-bit Office and 64-bit Windows:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Outlook\Addins\imFileSite.Connect
  4. Right-click the LoadBehavior value and then click Modify.
  5. Change the Value Data to 0, and then click OK.
  6. Close Registry Editor.
  7. Start Microsoft Outlook.


More Information


Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

http://autonomy.com

Here is the registration of the iManage add-in.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\imFileSite.Connect
or
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Outlook\Addins\imFileSite.Connect
(the registry path will vary depending on the Outlook and Windows bitness)

FriendlyName REG_SZ iManage FileSite Addin for Outlook 2010

Description REG_SZ iManage FileSite Addin for Outlook 2010
LoadBehavior REG_DWORD 0x3

Additional information about the .dll file used by the add-in. Note that the values below were identified in a specific case of this issue; version and build numbers may vary on a case by case basis.

Image path: C:\Program Files (x86)\Interwoven\WorkSite\IManage.dll
Image name: IManage.dll
Timestamp: Sat Nov 05 08:46:11 2011 (4EB53E23)
File version: 8.5.100.173
Product version: 8.5.100.67
CompanyName: Autonomy, Inc.
ProductName: WorkSite Object Model
InternalName: IMANAGE.DLL
OriginalFilename: IMANAGE.DLL
ProductVersion: 8.5.100.67
FileVersion: 8.5.100.173
PrivateBuild: 8.5.100.173
SpecialBuild: 8.5.100.173

FileDescription: WorkSite object model implementation

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