A backup that includes an SMB remote volume is unsuccessful in Windows Server 2012

Applies to: Windows 8Windows 8 EnterpriseWindows 8 Pro More

Symptoms


You run a backup on a computer that is running Windows Server 2012. To do this, you use a backup tool such as DiskShadow.exe to perform the backup for a local volume and for a server message block (SMB) file server remote volume. However, the backup is unsuccessful if the remote volume is added before the local volume, such as in a DiskShadow script.

For example, the backup is unsuccessful when you run a DiskShadow script that resembles the following:

#DiskShadow script file
set verbose on
Set Context Persistent
Set MetaData md.cab
begin backup
add volume \\Server\Share
add volume D:\

create

End backup
#End of script

Cause


This problem is caused by a mismatch that occurs when the Volume Shadow Copy Service (VSS) tries to find a volume device object that corresponds to the volumes that are listed in the DiskShadow script.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows 8
  • Windows Server 2012

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Workaround


To work around this issue, add remote volumes after you add local volumes in the script.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.