Cluster network name resource cannot be brought online when one of the domain controllers is partly down in Windows Server 2008 R2

Applies to: Windows Server 2008 R2 EnterpriseWindows Server 2008 R2 DatacenterWindows Server 2008 R2 for Itanium-Based Systems

Symptoms


Consider the following scenario:
  • You have a failover cluster that is running Windows Server 2008 R2 in a domain environment.
  • You have two domain controllers in the domain. For example, you have a primary domain controller DC1 and a secondary domain controller DC2 in the domain.
  • You create a cluster network name resource on DC1, and the cluster network name resource is brought online.
  • DC1 is partly down. More specifically, the Netlogon service on DC1 stops running, but the remote procedure call (RPC) service is still running.
In this scenario, the cluster network name resource cannot be brought online and goes to a "failed" state.

Cause


This issue occurs because the system assumes that DC1 is running correctly when the RPC service is running. When a cluster network name resource is brought online for the first time, an Active Directory object is created on DC1. Then, when DC1 is partly down, the system tries to update the object, and the Cluster service tries to locate a writable domain controller by checking the cached entry. The system assumes that DC1 is running correctly by checking the RPC service. However, because the Netlogon service is not running on DC1, the object cannot be updated.

You can confirm the cause of this issue by checking the cluster log. If the issue has occurred, a message in the cluster log resembles the following:
INFO [RES] Network Name <NetResourceName>: Initiating the Network Name operation : 'Verifying computer object associated with network name resource ServiceOrApplicationName'
INFO [RES] Network Name <NetResourceName>: Trying to find computer account <ServiceOrApplicationName> object GUID(95df46f8a2b1f946ab38a303c58bf33c) on any available domain controller.
WARN [RES] Network Name <NetResourceName>: Search for existing computer account failed. status 8007203A
WARN [RES] Network Name <NetResourceName>: Couldn't get information from DC <FQDN>. status 1717
INFO [RES] Network Name <NetResourceName>: Trying to find object 95df46f8a2b1f946ab38a303c58bf33c on a PDC.
WARN [RES] Network Name <NetResourceName>: Search for existing computer account failed. status 8007203A
INFO [RES] Network Name <NetResourceName>: Unable to find object 95df46f8a2b1f946ab38a303c58bf33c on a PDC.
INFO [RES] Network Name <NetResourceName>: GetComputerObjectViaGUIDEx() failed, Status 8007203A.

Note
The status code in the cluster log varies, depending on the configuration of the domain environment.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates