FIX: "TDDS failed to batch execution of streams" error message when you run A4SWIFT on a Microsoft BizTalk Server 2010 server

Vrijedi za: BizTalk Server Branch 2010BizTalk Server Developer 2010BizTalk Server Enterprise 2010 Više

Symptoms


When you run the Microsoft BizTalk 2010 Accelerator for SWIFT (A4SWIFT) on a server that is running Microsoft BizTalk Server 2010, the following error messages may be logged in the Application log:

datetime Warning 5 BAM EventBus Service servername.fqdn Execute batch error. Exception information: TDDS failed to batch execution of streams. SQLServer: server_name, Database: BAMPrimaryImport.Parameter is not valid.

datetime Error 6 BAM EventBus Service servername.fqdn Execute event error. Error(s) occurred while executing events, see TDDS_FailedTrackingData table for more details. SQLServer: server_name, Database: BAMPrimaryImport.

Note This problem occurs during the processing of an acknowledgment (ACK) or a negative acknowledgment (NACK) message.


Cause


This problem occurs because some important parameters, such as ErrorNack, Session, TimeSent, and Sequence, are not defined in the FrrActivities.xml definition file.

Resolution


Before you apply this fix, you must run the following command at an elevated command prompt:

C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking\bm.exe" remove-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Accelerator for SWIFT\BAMTracking\FrrActivities.xml 


After you apply this fix, you must run the following command at an elevated command prompt:

C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking\bm.exe" deploy-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Accelerator for SWIFT\BAMTracking\FrrActivities.xml" 

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have BizTalk Server 2010 installed.

Restart information

You do not have to restart the computer after you apply this hotfix.

Replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information