Call stack is corrupted when a native code application crashes on a Windows 7 SP1-based computer that has the AVX feature enabled

Symptoms

Consider the following scenario:

  • You enable the Advanced Vector Extensions (AVX) feature on a computer that is running an x64-based version of Windows 7 Service Pack 1 (SP1).
  • A 32-bit native code application crashes on the computer.
  • You try to use a debugger to debug the application
In this scenario, the application cannot be debugged because the call stack is corrupted.

Cause

This issue occurs because some functions do not save AVX registers when the function passes an exception to the debugger.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1. For more information about Windows 7 service packs, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the update in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this update.

Update replacement information

This update does not replace a previously released update.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:
2393659 A DHCP client computer that has multiple network adapters and that is running Windows 7 or Windows Server 2008 R2 cannot renew a DHCP lease when the computer wakes

Additional file information

Additional file information for Windows 7 SP1
Properties

Article ID: 2864432 - Last Review: Aug 15, 2013 - Revision: 1

Windows 7 Service Pack 1

Feedback