Project Web App 2010 can use IE 10 in compatibility mode


Summary


When accessing Project Web App on a computer with Internet Explorer 10, you may recieve the following error:

"This Project Server 2010 feature requires at least Microsoft Internet Explorer 7.0.

Troubleshoot issues with Micrsoft SharePoint Foundation.

Correlation ID: xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

Date and Time: dd/mm/yyyy hh:mm:ss"

Figure 1. Error message

 This Project Server 2010 feature requires at least Microsoft INternet Explorer 7.0

More Information


Internet Explorer 10 needs to run in Compatibility mode for all the pages in Project Web App 2010 to render without error.

To set IE 10 to run in Compatibility mode:

  1. Launch IE and then navigate to your Project Web App (PWA) home page.
  2. Select the Tools menu, If you don't see the Tools menu, then right click the empty space to the left of the Home icon and click Menu bar.
  3. From the Tools menu click Compatibility View settings
  4. Click Add button to add your PWA site to be viewed in compatibility view. 
  5. Click Close.

Repeat for additional sites that may require compatibility mode to view.

Figure 2. IE 10 Compatibility View settings dialog.

Compatibility View Settings