Symptoms
Logged on to the App Controller portal in a Self-Service User role, when opening the properties for a Virtual Machine the VM Network may show "not connected" despite the fact that the Virtual Machine is connected. If you close and reopen Properties, the correct Network Connection is shown.
Cause
This can occur if the required VM Networks are missing from the Self-Service User Roles Networking properties.
Resolution
To resolve this issue, go to the Self-Service User Roles Networking properties and add the VM Networks to which the VM is connected.