Symptoms
Consider the following scenario:
- You install Windows 8 or Windows Server 2012.
- You open Device Manager after the installation is complete.
The device is not working properly because Windows cannot load the drivers required for this device. (Code 31)
Cause
This issue occurs because Windows cannot load the drivers that are required for the WAN (Network monitor) device. Because there is no driver associated with the device, it cannot be removed from Device Manager.
Resolution
To prevent this issue during future installs, you must integrate update 2822241 into the installation media that you use during setup.
For information about how to use Deployment Image Servicing and Management (DISM) to integrate a hotfix package into installation media, see Add or remove packages offline.
For information about how to use Deployment Image Servicing and Management (DISM) to integrate a hotfix package into installation media, see Add or remove packages offline.
Workaround
To work around the problem, go to the "Fix it for me" section. If you prefer to work around the problem yourself, go to the "Let me fix it myself" section.