Code 31 error in Device Manager for WAN Miniport (Network monitor) device in Windows 8 or Windows Server 2012

Symptoms

Consider the following scenario:
  • You install Windows 8 or Windows Server 2012.
  • You open Device Manager after the installation is complete.
In this scenario, Device Manager displays a yellow exclamation mark next to the WAN Miniport (Network monitor) device. Additionally, the Details tab of the device properties window displays the following message:

The device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

Cause

This issue occurs because Windows cannot load the drivers that are required for the WAN (Network monitor) device. Because there is no driver associated with the device, it cannot be removed from Device Manager.

Resolution

To prevent this issue during future installs, you must integrate update 2822241 into the installation media that you use during setup.

For information about how to use Deployment Image Servicing and Management (DISM) to integrate a hotfix package into installation media, see Add or remove packages offline.

Workaround

To work around the problem, go to the "Fix it for me" section. If you prefer to work around the problem yourself, go to the "Let me fix it myself" section.



Fix it for me

To work around the problem, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.





Notes

Let me fix it myself
Properties

Article ID: 2871372 - Last Review: Oct 16, 2013 - Revision: 1

Windows 8, Windows Server 2012 Standard, Windows Server 2012 Standard, Windows Server 2012 Standard, Windows Server 2012 Standard, Windows Server 2012 Datacenter, Windows Server 2012 Datacenter, Windows Server 2012 Datacenter, Windows Server 2012 Datacenter

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