Error message when you try to perform a LUN resynchronization in Windows Server 2012 or Windows Server 2008 R2 SP1

Symptoms

Consider the following scenario:
  • You have cluster disk resources configured on a Windows Server 2012-based or Windows Server 2008 R2 Service Pack 1 (SP1)-based failover cluster.
  • You create Volume Shadow Copy Service (VSS) snapshots for some volumes.
  • You try to perform a logical unit number (LUN) resynchronization on the volumes.
In this scenario, the LUN resynchronization operation fails. Additionally, you receive an error message that resembles the following:
The LUN resynchronization operation failed after calling the hardware provider. The data on the destination LUNs is probably intact. However, the LUNs may have incorrect disk signatures. To retry the resynchronization, recreate the destination LUNs and retry the operation.

Note
This issue also occurs when an application uses the LUN resynchronization feature.

Cause

This issue occurs because drive is marked as "read-only" incorrectly.

Resolution

To fix this issue, we have released an update through Windows Update for Windows Server 2012. And we also have released a hotfix for Windows Server 2012 and Windows Server 2008 R2 SP1. Even though this issue is observed only in Windows Server 2012 or Windows Server 2008 R2 SP1, the update or hotfix also applies to Windows 8, Windows RT, and Windows 7 SP1.

Method 1: Windows Update

This update is provided as an Optional update on Windows Update for Windows Server 2012. For more information on how to run Windows Update, see How to get an update through Windows Update.

Method 2: Hotfix package for Windows Server 2012 and Windows Server 2008 R2 SP1

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

File Information

The English (United States) version of this software update installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). Be aware that dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time bias. The dates and times may also change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2
Windows 8 and Windows Server 2012
Additional file information
Properties

Article ID: 2877115 - Last Review: Nov 26, 2015 - Revision: 1

Windows Server 2008 R2 Service Pack 1, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 Standard, Windows Web Server 2008 R2, Windows Server 2008 R2 for Itanium-Based Systems, Windows Server 2012 Datacenter, Windows Server 2012 Datacenter, Windows Server 2012 Datacenter, Windows Server 2012 Datacenter, Windows Server 2012 Standard, Windows Server 2012 Standard, Windows Server 2012 Standard, Windows Server 2012 Standard, Windows Server 2012 Essentials, Windows Server 2012 Foundation, Windows Server 2012 Foundation, Windows Server 2012 Foundation, Windows Server 2012 Foundation

Feedback