Smart card logon option is displayed incorrectly on the logon screen in Windows 8 or Windows Server 2012

S’applique à : Windows 8Windows 8 EnterpriseWindows 8 Pro

Symptoms


When you use a virtual smart card on a computer that is running Windows 8 or Windows Server 2012, you experience one of the following issues.

Issue 1

After you restart the computer, the virtual smart card logon option is not displayed on the logon screen.

Note After a user logs on to the computer by using a password and then logs off from the computer, the virtual smart card logon option is displayed as expected on the logon screen.

Issue 2

Assume that you have a physical smart card reader connected to the computer, and there is no physical smart card in the smart card reader. After you lock the computer, the virtual smart card logon option is displayed on the logon screen as expected. However, the physical smart card logon option is displayed unexpectedly on the logon screen. Additionally, if you click the physical smart card logon option, the "Checking Status" status is displayed indefinitely instead of the expected "Insert Smart Card" status.

Cause


This issue occurs because there is no order for enumerating smart cards and updating smart card reader information. If smart card reader information is updated before smart card enumeration is performed, the issues that are described in the "Symptoms" section occur.

Resolution


This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates