"0xC0000203" error when you try to access a DFS share that is located on a Windows Server 2003 R2 or earlier version of Windows-based computer from a Windows 7 SP1 or Windows Server 2008 R2 SP1-based computer

Symptoms

Assume that you have a Distributed File System (DFS) share on a computer that is running Windows Server 2003 R2 or an earlier version of Windows. You try to access the DFS share from a computer that is running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1. In this situation, the Server Message Block version 1 (SMBv1) protocol is used during the access attempt. However, the access attempt fails, and you receive an error message that resembles the following: 
0xC0000203 (STATUS_USER_SESSION_DELETED)

Note
 SMBv1 protocol is used because Windows Server 2003 R2 or an earlier version of Windows only supports SMBv1. This issue does not occur in SMBv2 or SMBv3.

Cause

This issue occurs because in SMBv1, if a context object that refers the current session is used in a work thread, but reused in another work thread, the system decreases the number of active context objects incorrectly. Therefore, the session object is deleted incorrectly because of this behavior.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information
Properties

Article ID: 2883703 - Last Review: Oct 9, 2013 - Revision: 1

Windows Server 2008 R2 Service Pack 1, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 for Itanium-Based Systems, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 Standard, Windows Web Server 2008 R2, Windows 7 Service Pack 1, Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Starter, Windows 7 Ultimate

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