Large backlogs on Windows -based DFSR servers

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 EssentialsWindows Server 2012 R2 Foundation More

Symptoms


Assume that you have Windows Server 2008 R2 Service Pack 1 (SP1)-based servers, Windows Server 2012 R2-based servers, or Windows Server 2012-based servers that use the Distributed File System Replication (DFSR) service. You have a DFSR replication topology in your environment. In this situation, you experience a spike of backlogs on a daily or weekly basis. Additionally, in the DFSR debug log, you notice that the "GcTask::refreshrecord" entry refreshes lots of records regularly.

Cause


This issue occurs when the garbage collection task (GCTask) of DFSR refreshes the stale records. When a garbage collection task processes the version vector tombstone of a content set before the non-version vector tombstone, the task considers all the records that belong to the content set to be stale. Therefore, the records are refreshed, and the issue that is described in the "Symptoms" section occurs.

Resolution


To resolve this issue, we have released a hotfix for Windows Server 2012 or Windows Server 2008 R2, and we have released an update rollup for Windows 8.1 or Windows Server 2012 R2.

Get the update rollup for Windows Server 2012 R2

To resolve this issue, install the November 2014 update rollup for Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2.

Get the hotfix for Windows Server 2012 or Windows Server 2008 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates