Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Warning: The retired, out-of-support Internet Explorer 11 desktop application has been permanently disabled through a Microsoft Edge update on certain versions of Windows 10. For more information, see Internet Explorer 11 desktop app retirement FAQ.

Symptoms

Consider the following scenario:

  • You have a computer that is running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.

  • In Windows Internet Explorer, you open Internet Options, then you select Empty Temporary Internet Files folder when browser is closed under the Advanced tab. Then, you click OK to save the setting.

  • You download and run an .exe file directly by using Internet Explorer. 

    Note You do not select "Save as" to download the file and save it on the computer.

  • You close Internet Explorer, and then you reopen it.

  • You try to download another file by using Internet Explorer.

In this scenario, you cannot download the file, and you receive an error message that resembles the following:

Filename couldn't be downloaded
 

Note You can temporarily resolve this issue by restarting the computer.

Cause

This issue is caused by a handle leak that occurs in Windows. The handle leak then prevents Internet Explorer from emptying the Temporary Internet Files folder after you close Internet Explorer. Therefore, after you reopen Internet Explorer, you cannot download any files.
 

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
 

976932Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2
 

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760
    1.22xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Pcaui.dll

6.1.7601.22469

87,040

01-Oct-2013

02:07

Aelupsvc.dll

6.1.7600.16385

62,464

14-Jul-2009

01:14

Apphelp.dll

6.1.7601.22469

295,936

01-Oct-2013

02:04

Sdbinst.exe

6.0.7600.16385

20,992

14-Jul-2009

01:14

Shimeng.dll

6.1.7600.16385

5,120

14-Jul-2009

01:16

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Pcaui.dll

6.1.7601.22469

97,792

01-Oct-2013

02:31

Aelupsvc.dll

6.1.7600.16385

72,192

14-Jul-2009

01:40

Apphelp.dll

6.1.7601.22469

342,016

01-Oct-2013

02:28

Sdbinst.exe

6.0.7600.16385

23,552

14-Jul-2009

01:39

Shimeng.dll

6.1.7600.16385

6,656

14-Jul-2009

01:41

Apphelp.dll

6.1.7601.22469

295,936

01-Oct-2013

02:04

Sdbinst.exe

6.0.7600.16385

20,992

14-Jul-2009

01:14

Shimeng.dll

6.1.7600.16385

5,120

14-Jul-2009

01:16

Pcaui.dll

6.1.7601.22469

87,040

01-Oct-2013

02:07

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Pcaui.dll

6.1.7601.22469

195,072

01-Oct-2013

01:42

Aelupsvc.dll

6.1.7600.16385

124,928

14-Jul-2009

01:45

Apphelp.dll

6.1.7601.22469

556,544

01-Oct-2013

01:40

Sdbinst.exe

6.0.7600.16385

46,592

14-Jul-2009

01:44

Shimeng.dll

6.1.7600.16385

6,656

14-Jul-2009

01:49

Apphelp.dll

6.1.7601.22469

295,936

01-Oct-2013

02:04

Sdbinst.exe

6.0.7600.16385

20,992

14-Jul-2009

01:14

Shimeng.dll

6.1.7600.16385

5,120

14-Jul-2009

01:16

Pcaui.dll

6.1.7601.22469

87,040

01-Oct-2013

02:07

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
 

824684Description of the standard terminology that is used to describe Microsoft software updates
 

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File property

Value

File name

X86_b3b899daf1b2a56c833a6d74c511fb59_31bf3856ad364e35_6.1.7601.22449_none_150297c5a7cead1d.manifest

File version

Not applicable

File size

725

Date (UTC)

13-Sep-2013

Time (UTC)

07:42

Platform

Not applicable

File name

X86_microsoft-windows-a..ence-infrastructure_31bf3856ad364e35_6.1.7601.22449_none_d786818ec42d8171.manifest

File version

Not applicable

File size

16,143

Date (UTC)

12-Sep-2013

Time (UTC)

02:37

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File property

Value

File name

Amd64_8f7f42ac5102cbac24812cb68d375f01_31bf3856ad364e35_6.1.7601.22449_none_c8e81fb15b688e79.manifest

File version

Not applicable

File size

729

Date (UTC)

13-Sep-2013

Time (UTC)

07:42

Platform

Not applicable

File name

Amd64_b3c675aa092671267ca3f7197ba4818a_31bf3856ad364e35_6.1.7601.22449_none_82bee7cf05fdc131.manifest

File version

Not applicable

File size

729

Date (UTC)

13-Sep-2013

Time (UTC)

07:42

Platform

Not applicable

File name

Amd64_b4d8c9d4e12000b1da69b300976a57ef_31bf3856ad364e35_6.1.7601.22449_none_993fa01493ba2297.manifest

File version

Not applicable

File size

1,100

Date (UTC)

13-Sep-2013

Time (UTC)

07:42

Platform

Not applicable

File name

Amd64_microsoft-windows-a..ence-infrastructure_31bf3856ad364e35_6.1.7601.22449_none_33a51d127c8af2a7.manifest

File version

Not applicable

File size

16,474

Date (UTC)

12-Sep-2013

Time (UTC)

02:54

Platform

Not applicable

File name

Wow64_microsoft-windows-a..ence-infrastructure_31bf3856ad364e35_6.1.7601.22449_none_3df9c764b0ebb4a2.manifest

File version

Not applicable

File size

13,498

Date (UTC)

12-Sep-2013

Time (UTC)

02:21

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File property

Value

File name

Ia64_c4a33488e09c9c7197711662b3aa9702_31bf3856ad364e35_6.1.7601.22449_none_a160e0b174cd2d4a.manifest

File version

Not applicable

File size

1,098

Date (UTC)

13-Sep-2013

Time (UTC)

07:42

Platform

Not applicable

File name

Ia64_microsoft-windows-a..ence-infrastructure_31bf3856ad364e35_6.1.7601.22449_none_d7882584c42b8a6d.manifest

File version

Not applicable

File size

16,471

Date (UTC)

12-Sep-2013

Time (UTC)

02:20

Platform

Not applicable

File name

Wow64_microsoft-windows-a..ence-infrastructure_31bf3856ad364e35_6.1.7601.22449_none_3df9c764b0ebb4a2.manifest

File version

Not applicable

File size

13,498

Date (UTC)

12-Sep-2013

Time (UTC)

02:21

Platform

Not applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×