Error message when you try to schedule a shadow copy task in Windows Server 2012 R2 or in Windows Server 2012

Symptoms

Assume that you have a Windows Server 2012 R2-based or Windows Server 2012-based failover cluster that uses the Windows Volume Shadow Copy feature. You try to schedule a shadow copy task. For example, in Windows Explorer, you right-click a shared disk, and then you click Properties. Under the Shadow Copies tab, you select the shared disk, and then you click Enable.

In this situation, the shadow copy task is not created immediately. After some time, you receive an error message that resembles the following:
Failed to create a default schedule for creating shadow copies of volume xx. Error 0x80070102: The wait operation timed out

Note
  • The shadow copy task may be created after several hours.
  • You may receive another error message that resembles the following:
    0x80004005: Unspecified error

Cause

This issue occurs because a worker thread incorrectly maintains a slim reader/writer (SRW) lock when the worker thread is in sleep state. Therefore, the listener thread cannot obtain the lock to push the work item into the queue.

Resolution

To resolve this issue in Windows Server 2012 R2, install update rollup 2887595. 

To resolve this issue in Windows Server 2012, install update rollup 2903938, or install the hotfix that is described in this article.


Update information for Windows Server 2012 R2

For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
2887595 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: November 2013

Update information for Windows Server 2012

For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
2903938 Windows RT, Windows 8, and Windows Server 2012 update rollup: December 2013

Hotfix information for Windows Server 2012

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix or the update, you must be running Windows Server 2012 or Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information
Properties

Article ID: 2894464 - Last Review: Dec 10, 2013 - Revision: 1

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