Can't mount more than 50 databases per server after you upgrade to Exchange Server 2013 Cumulative update 2

Applies to: Exchange Server 2013 Enterprise

Symptoms


Consider the following scenario:
  • You are using Microsoft Exchange Server 2013 Enterprise Edition.
  • You upgrade Exchange 2013 servers from Cumulative Update 1 to Cumulative update 2.
  • You try to mount more than 50 databases on a Mailbox server.
In scenario, you receive the following error message:

Couldn't mount the database that you specified. Specified database: Test1; Error code: An Active
Manager operation failed. Error: The database action failed. Error: Operation failed with message:
MapiExceptionTooManyMountedDatabases: Unable to mount database. (hr=0x8004060e, ec=-2147219954)

Resolution


To resolve this issue, make sure that the msExchMaxStoresTotal attribute on the CN=InformationStore container is set to 100. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type Adsiedit.msc, and then click OK.
  3. Right-click ADSI Edit, and then click Connect to.
  4. In the Select a well know Naming Context list, select Default naming context. In the Select or type a domain or server box, type the FQDN of a domain controller server, and then click OK.
  5. Expand to the path to the following:

    Configuration [DC.domain.com]; CN=Configuration, DC=domain, DC=com; CN=Services; CN=Microsoft Exchange; CN=<Your Organization>; CN= Administrative Groups; CN=<Exchange Org name>; CN=Servers; CN=<the Mailbox Server name>; CN=Information Store
  6. Right-click CN=InformationStore, and then click Properties.
  7. In the Attributes list, double-click msExchMaxStoresTotal, and then set the value to 100.
Note You must restart the Microsoft Exchange Information Store service for this change to take effect.

More Information


Enterprise Edition can scale to 50 mounted databases per server in the RTM and Cumulative Update 1 (CU1) versions. And Enterprise Edition can scale to 100 mounted databases per server in Cumulative Update 2 (CU2) and later versions. For more information, see Exchange 2013: editions and versions.