Stop error 0x50 in the Win32k.sys driver after you install a font update

Attiecas uz: Windows 7 Service Pack 1Windows Server 2008 R2 Service Pack 1

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms


You install a font update on a computer that's running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 Service Pack 1 (SP1). However, the system experiences Stop error 0x50 in the Win32k.sys driver. This error occurs when you do any of the following:
  • You restart the computer.
  • You start a program, such as an Office program.
  • You use Windows Explorer to browse to the font folder.

Cause


This problem occurs because the old font cache data was not cleared correctly. Therefore, the system incorrectly treats the font data as corrupted.

Resolution


Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.