Lightweight Directory Services auditing Event ID 4662 is missing user information

Applies to: Windows Server 2008 R2 StandardWindows Server 2008 R2 EnterpriseWindows Server 2008 R2 Datacenter

Symptoms


Consider the following scenario:
  • You have an Active Directory Lightweight Directory Services (AD LDS) deployment on a server that is running Windows Server 2008 R2.
  • You successfully configure Object Access Auditing to access objects in the AD LDS deployment.

In this scenario, the user name, domain name, and security ID (SID) are missing intermittently in a logged Event 4662. Therefore, no information is available about the user who is making the access. For example, see the following Event 4662 log entry:

Cause


This problem occurs because of a timing issue between the time that the access and the event log are queued and the time that the logon session ID is resolved for the user and domain name. In this case, the logon session is ended, and the details are not logged correctly.

Resolution


To resolve this problem, apply this hotfix on all active instances of Lightweight Directory Services.

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.





Restart requirement

You do not have to restart the server after you apply this hotfix if no Remote Server Administration Tools were run. 

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Workaround


To work around this problem, enable successful logon auditing and match the "Logon_ID" in the event 4662 entry to a successful logon audit event from which you will find the user_name and domain_name.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.