"You must have Windows PowerShell 2.0 or greater installed" error when you try to install Azure Active Directory Module for Windows PowerShell

Applies to: Azure Active DirectoryOffice 365 User and Domain ManagementOffice 365 Identity Management

PROBLEM


When you try to install Azure Active Directory Module for Windows PowerShell, you receive the following error message: 
In order to install Windows Azure Active Directory Module for PowerShell, you must have Windows PowerShell 2.0 or greater installed on this computer.

SOLUTION


To resolve this issue, try one of the following methods. If one doesn't work for you, try another one.

Method 1: Install Azure Active Directory Module for Windows PowerShell when you log on as local admin

  1. Log on as a local admin. (Just logging on as a domain admin may not work.)
  2. Install Azure Active Directory Module for PowerShell.

Method 2: Make sure that Windows PowerShell 2.0 is enabled

  1. Log on as a local admin. (Just logging on as a domain admin may not work.)
  2. In Control Panel, click Programs and Features, or click Uninstall a program under Programs.
  3. Click Turn Window features on or off.
  4. In the Windows Feature window, make sure that the Windows PowerShell 2.0 check box is selected, and then click OK.
  5. Install Azure Active Directory Module for PowerShell.


Still need help? Go to Microsoft Community.