Explorer.exe process is not terminated when you close the Printers folder

Applies to: Windows Server 2008 Service Pack 2Windows Server 2008 DatacenterWindows Server 2008 Datacenter without Hyper-V

Symptoms


Consider the following scenario:
  • You open the Printers folder by using the Explorer.exe ::{2227A280-3AEA-1069-A2DE-08002B30309D} commandin the Open field of the Run dialog box on a computer that is running Windows Server 2008 Service Pack 2 (SP2). A new Explorer.exe process is created for the Printers folder.

    Note The details of the newly started Explorer.exe process can be viewed in Windows Task Manager.
  • You select one or more printers, or you click the Add a printer button in the folder.
  • You close the Printers folder.
In this scenario, the Printers folder is closed as expected. However, the newly started Explorer.exe process persists, and therefore continues to use memory.

Note If you de-select the printer before you close the Printers folder, the Explorer.exe process is terminated as expected.

Cause


This issue occurs because the printer object is not removed from the cache when the window is closed.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 SP2. For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates