Outlook may take two to three minutes to connect to an Office 365 mailbox

Applies to: Windows 8.1Windows 8.1 EnterpriseWindows 8.1 Pro

Symptoms


Consider the following scenario:
  • You have a third-party proxy server that enables communication only over port 80.
  • You configure a computer that is running one of the following operating systems to use this proxy server for all protocols:
    • Windows 8.1
    • Windows Server 2012 R2
    • Windows 7
    • Windows Server 2008 R2
  • You configure the proxy bypass list to contain settings for internal servers.
  • You enable the Bypass proxy server for local addresses option.
  • You configure Microsoft Outlook 2010 or Microsoft Outlook 2013 to connect to the newest Microsoft Office 365 mailbox (Wave15).
  • You start Outlook, and it tries to connect to Outlook.Office365.com.

In this scenario, it takes two to three minutes to obtain the initial connection.

Cause


This problem occurs because RPC waits for the direct connection to time out before it selects the proxy server. This causes the delay.

Resolution


Update information for Windows 8.1 and Windows Server 2012 R2

To resolve this problem for Windows 8.1 and Windows Server 2012 R2, take both of the following actions:
  • Apply Windows update 2919355 .
  • Apply either Outlook 2013 update 2878323 or Outlook 2010 update 2878254 , depending on your configuration.
  • Create the EnableForceHttpProxy registry value and set it to 1.

    To create the EnableForceHttpProxy registry value, follow these steps:
    1. Exit Outlook.
    2. Start Registry Editor.

      Swipe in from the right to open the charms, tap or click Search, and then type regedit.exe in the search box. Or, type regedit.exe at the Start screen, and then tap or click regedit in the search results.
    3. Locate and then select the following registry key:

      HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\RPC


      Note In this key path, the placeholder x.0represents 15.0 for Outlook 2013 and 14.0 for Outlook 2010.
    4. On the Edit menu, click New, and then click DWORD Value.
    5. Type EnableForceHttpProxy.
    6. On the Edit menu, click Modify.
    7. Type 1, and then click OK.
    8. Exit Registry Editor.
    9. Start Outlook.

Update information for Windows 7 and Windows Server 2008 R2

To resolve this problem for Windows 7 and Windows Server 2008 R2, take both of the following actions:
  • Apply the Windows hotfix that is mentioned in this article.
  • Apply either Outlook 2013 update 2878323 or Outlook 2010 update 2878254 , depending on your configuration.
  • Create the EnableForceHttpProxy registry value and set it to 1.

    To create the EnableForceHttpProxy registry value, follow these steps:
    1. Exit Outlook.
    2. Start Registry Editor.

      Click Start, type regedit in the Start Search box, and then press Enter. If you are prompted for an administrator password or for confirmation, type the password, or click Allow.
    3. Locate and then select the following registry key:

      HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\RPC


      Note In this key path, the placeholder x.0represents 15.0 for Outlook 2013 and 14.0 for Outlook 2010.
    4. On the Edit menu, click New, and then click DWORD Value.
    5. Type EnableForceHttpProxy.
    6. On the Edit menu, click Modify.
    7. Type 1, and then click OK.
    8. Exit Registry Editor.
    9. Start Outlook.

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


This hotfix adds the following non-user-configurable registry key:

Registry location: HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc
DWORD name: ConnectionOptionsFlag
DWORD value: 00000001


Note Changing this registry key will not change the RPC behavior. This key is added only to indicate the presence of a new HTTP connection option.

The delay may still occur for connections to shared folders. This is because a shared folder is not added as an Exchange mailbox account. Therefore, Outlook is unable to determine if it is located on an Exchange Online mailbox.

References


Learn about the terminology that Microsoft uses to describe software updates.