White line appears when printing an image by using an XPS printer driver in Windows

Applies to: Windows 8.1 EnterpriseWindows 8.1Windows 8.1 Pro

Symptoms


When you print an image by using an XPS printer driver on a computer that is running Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, Windows 7 or Windows Server 2008 R2 unexpected white lines appear in the printed image.

Cause


This issue is caused by a margin error in the XPS-to-GDI converter (XGC) that executes conversions from floating point to integer.

Resolution


For Windows 8.1 and Windows Server 2012 R2

If you are using Windows 8.1 or Windows Server 2012 R2, to resolve this issue, install update rollup 2919394. For more information about how to obtain this update rollup package, click the following article number to go to the article in the Microsoft Knowledge Base:
2919394 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: February 2014

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates