Resource Monitor (Perfmon /res) crashes in Windows 7 and in Windows Server 2008 R2

Attiecas uz: Windows 7 Service Pack 1Windows Server 2008 R2 Service Pack 1

Symptoms


If you use Windows Task Manager or the Perfmon /res command to start Resource Monitor on a computer that is running Windows 7 or Windows Server 2008 R2, the Perfmon.exe process crashes. Additionally, you receive an error message that resembles the following:

Faulting application name: perfmon.exe, version: 6.1.7601.17514, time stamp: 0x4ce7972c
Faulting module name: wdc.dll, version: 6.1.7601.21854, time stamp: 0x4eb38833
Exception code: 0xc0000005
Fault offset: 0x0000000000061a1c
Faulting process id: 0x548
Faulting application start time: 0x01ceb90f1d977b61
Faulting application path: C:\Windows\System32\perfmon.exe
Faulting module path: C:\Windows\System32\wdc.dll
Report Id: 63bef6f4-2502-11e3-bfa7-d89d671f169f

Cause


This problem occurs because of a race condition in the WDC.dll module.

Resolution


Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology  that Microsoft uses to describe software updates.