Selected media size does not work for print jobs on a printer in Windows 8.1 and Windows 8

Applies to: Windows 8.1 EnterpriseWindows 8.1Windows 8.1 Pro

Symptoms


Consider the following scenario:
  • You have a computer that runs Windows 8.1, Windows Server 2012 R2, Windows 8 or Windows Server 2012.
  • You connect a printer to the computer.
  • The printer uses a v4 PostScript driver that is based on the MsXpsPs.dll filter or on the MsXpsPcl6.dll filter.
  • You select a specific media size for a print job.
In this scenario, the print driver sends the default media size information instead. Therefore, the print job is not printed by using the specified media size.

Cause


This issue occurs because the PageSize and PageRegion commands generated by the MsXpsPs.dll or MsXpsPcl.dll filter in the v4 PostScript drivers do not consider the selected paper size.

Resolution


To resolve this issue for Windows 8.1 and Windows Server 2012 R2, install update rollup 2919355 or install the hotfix that is described in this article.
To resolve this issue for Windows 8 and Windows Server 2012, install the hotfix that is described in this article.

Update information for Windows 8.1 and Windows Server 2012 R2

For more information about how to obtain update 2919355, click the following article number to view the article in the Microsoft Knowledge Base:
2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8.1, Windows Server 2012 R2, Windows 8 or Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates