Outlook Web App cross-site silent redirection does not work in Exchange Server 2013

Applies to: Exchange Server 2013 EnterpriseExchange Server 2013 Standard Edition

Symptoms


Consider the following scenario:
  • You have two Active Directory sites in a Microsoft Exchange Server 2013 environment that has Cumulative Update 3 installed.
  • Each site has a different External URL configured.
  • Form-based authentication is configured for Outlook Web App virtual directories in both Active Directory sites.
  • You have set cross-site silent redirection for Outlook Web App.
  • A user accesses another site’s Outlook Web App URL.
In this scenario, the user sees a manual redirection message and the External URL of the Client Access server in the other Active Directory site. We expect that the user experiences silent redirection to the External URL.

Cause


This issue occurs because of a logic defect in Outlook Web App proxy and redirection.

Resolution


To resolve this issue, install the following service pack: 
2926248 Description of Exchange Server 2013 Service Pack 1

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about how to set form-based authentication by running the Set-OwaVirtualDirectory cmdlet, go to the following Microsoft website:For more information about how to configure Outlook Web App virtual directories, go to the following Microsoft website:For more information about proxying and redirection, go to the following Microsoft website:For more information about Outlook Web App cross-site silent redirection, go to the following Microsoft website: