HTTP 500 error when a user tries to publish the calendar of a shared mailbox in Microsoft 365
Original KB number: 2934901
Symptoms
When a user who has Full Access permission to a shared mailbox in Microsoft 365 tries to publish the calendar of the shared mailbox, the user receives an HTTP 500 error message.
Cause
This issue occurs if the user isn't the mailbox owner. Only mailbox owners can publish a calendar externally.
Workaround
Connect to Exchange Online by using remote PowerShell. For more info about how to do this, see Connect to Exchange Online PowerShell.
Run the following command to publish the calendar folder of a mailbox:
Set-MailboxCalendarFolder -Identity <user>:\Calendar -PublishEnabled:$True -PublishDateRangeFrom ThreeMonths -PublishDateRangeTo SixMonths -DetailLevel LimitedDetails
Note
Set the
-DetailLevel
parameter to the value that's appropriate for you. The options areAvailabilityOnly
,LimitedDetails
, andFullDetails
. In this example, the parameter is set toLimitedDetails
.Run the following command to view the published URL of the calendar folder:
Get-MailboxCalendarFolder -Identity <user>:\Calendar
More information
For more information about the Set-MailboxCalendarFolder
and Get-MailboxCalendarFolder
cmdlets, see the following Microsoft websites:
Still need help? Go to Microsoft Community.
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