You don't receive any confirmation after you successfully schedule a meeting or an appointment for an on-premises room mailbox in either Outlook client or Outlook Web App in Office 365

Applies to: Exchange OnlineMicrosoft 365 Apps for enterprise

PROBLEM


When you schedule a meeting or an appointment for an on-premises room mailbox in either Microsoft Office Outlook client or Microsoft Outlook Web App (OWA) in Microsoft Office 365, the meeting is successfully booked, and the calendar of the room mailbox is blocked or marked as Tentative. However, you don't receive any confirmation that states that the room mailbox is successfully booked.

CAUSE 


This issue occurs if the ProcessExternalMeetingMessages parameter for the room mailbox is set to False.

SOLUTION


To resolve this issue, set the ProcessExternalMeetingMessages parameter to True. To do this, run the following cmdlet in Microsoft Exchange Management Shell:

Set-CalendarProcessing "<Room Name>" –ProcessExternalMeetingMessages $True 
Note This setting will affects non-hybrid users.

For more information about this cmdlet, see Set-CalendarProcessing.

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