"0xD1" Stop error occurs occasionally in all SQL Server cluster nodes running Windows 7 or Windows Server 2008 R2

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms

When this issue occurs, Microsoft SQL Server cluster nodes that are running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1 crash, and you receive a Stop error message that resembles the following:
STOP: 0x000000D1 (parameter1, parameter2, parameter3, parameter4)

Notes
  • This Stop error describes a DRIVER_IRQL_NOT_LESS_OR_EQUAL issue.
  • The parameters in this Stop error message vary, depending on the configuration of the computer.
  • Not all "Stop 0x000000D1" errors are caused by this issue.

Cause

This issue occurs because a TCP connection is closed before the TCP data-sending process is complete. Then, the TCP data-sending process tries to access resources that do not exist.  

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must first install the Service Pack 1 on Windows 7 or Windows Server 2008 R2.  For more information, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information
Properties

Article ID: 2958399 - Last Review: Oct 9, 2014 - Revision: 1

Windows 7 Service Pack 1, Windows 7 Enterprise, Windows 7 Professional, Windows 7 Ultimate, Windows Server 2008 R2 Service Pack 1, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 Standard, Windows Server 2008 R2 for Itanium-Based Systems

Feedback