An upgrade from SCVMM 2012 SP1 to SCVMM 2012 R2 fails and returns a "database can not be upgraded" error message

Applies to: Microsoft System Center 2012 R2 Virtual Machine Manager

Symptoms


When you try to upgrade from Microsoft System Center 2012 Virtual Machine Manager (SCVMM) Service Pack 1 (SP1) to System Center 2012 R2 Virtual Machine Manager, the process fails, and you receive the following error message:

The Virtual Machine Manager database can not be upgraded. The Virtual Machine Manager VirtualManagerDB was not upgraded. Try a new database and run setup again.

Cause


This problem occurs because SCVMM 2012 R2 requires that the VirtualManagerDB database and the Microsoft SQL Server instance be at level of SQL Server 2008 R2 Service Pack 2 (SP2) or a later version.

Resolution


To resolve this problem, follow these steps:
  1. Upgrade the SQL Server instance to SQL Server 2008 R2 SP2.
  2. Raise the level of the VirtualManagerDB database to SQL Server 2008 R2 SP2.

More Information


For more information about the SQL Server instance level, see the following Microsoft TechNet topic:

Note This topic does not mention that the SQL Server-based VMM database must also be at level of SQL Server 2008 R2 SP2 or a later version.