"Your Automatic reply settings cannot be displayed" Outlook error in a multi-forest configuration of Exchange Server

Applies to: Microsoft Outlook 2010

Symptoms


Consider the following scenario:
  • You log on to Windows by using your account from Forest A.
  • You use Microsoft Outlook 2010 to connect to your mailbox on a Microsoft Exchange Server 2010 server that's in Forest B.
  • Outlook 2010 uses your Windows credentials.
  • You open a mailbox profile in Outlook 2010 by using credentials that differ from the credentials that you used to log on to Windows. 
  • You try to open the Out of Office Assistant in Outlook 2010.
In this scenario, you receive the following error message:
Your Automatic reply settings cannot be displayed because the server is currently unavailable. Try again later.

Cause


This problem occurs because the Exchange CAS server uses the credentials that you used to log on to Windows instead of the credentials that you used to log on to the Exchange mailbox. Because the Windows credentials do not match the mailbox credentials, the CAS server returns a "500" error code. However, the "500" error is not an authentication error code. Therefore, no other authentication methods are tried.

Resolution


Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To resolve this issue, apply the following update:
2584053 Description of the Outlook 2010 hotfix package (x86 Outlook-x-none.msp; x64 Outlook-x-none.msp): August 30, 2011

Registry key information

After you apply the hotfix package, follow these steps to enable the hotfix:
  1. Exit Outlook.
  2. Start Registry Editor.
    In Windows 8 and Windows 8.1

    Swipe in from the right side to open the charms, tap or click Search, and then type regedit.exe in the search box. Or, type regedit.exe at the Start screen, and then tap or click regedit in the search results.

    In Windows Vista and Windows 7

    Click Start, type regedit in the Start Search box, and then press Enter. If you are prompted for an administrator password or for confirmation, type the password, or click Allow.

    In Windows XP

    Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security
  4. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
  5. Type WinhttpAuth, and then press ENTER.
  6. In the Details pane, right-click WinhttpAuth, and then click Modify.
  7. In the Value data box, type 2, and then click OK.
  8. Exit Registry Editor.

More Information


The following table lists the different possible values for the WinhttpAuth registry value:
0 (or missing)Default Outlook behavior. The issue that is described in the "Symptoms" section may still occur.
1Sets the Winhttp class calls to a high level. This instructs Winhttp to use the credentials that you used to log on to the mailbox in Outlook instead of the credentials that you used to log on to Windows.
2Sets the Autodiscover class calls to a high level. You can use this value to change security contexts.
3Sets both class calls to a high level.