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Symptoms

Consider the following scenario:


In the scenario, existing clients that already have an authentication cookie may be unable to access published resources and may receive the following error message:

1413 Invalid Index.


Note This problem mainly affects Exchange ActiveSync users when their mobile device keeps using the old cookie until the device is restarted or cleared by the server.

Cause

Cookie sharing across array members uses a new cookie format, and the authentication cookie that is provided by existing clients is not cleared correctly after the cookie-sharing feature is enabled.

Resolution

To resolve this problem, install Rollup 5 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 2.

Workaround

To work around this problem, change the cookie name that is defined on the web listener. To do this, follow these steps:

  1. Open the Forefront TMG Management console, and then click Firewall Policy.

  2. On the Toolbox tab in the right-side pane, expand Network Objects.

  3. Expand Web Listeners, right-click the listener that was used to publish the problem websites, and then click Properties.

  4. On the Forms tab, click Advanced.

  5. In the Cookie Name field, type a different cookie name such as cadata2.

    Note By default, this field is blank, and the default cookie name that is used is cadata.

  6. Click OK, and then click OK again to exit the dialog boxes.

  7. Click Apply to save the changes.

Wait for the changes to synchronize to the Forefront TMG Firewall Service. To do this, click Monitoring, and then click Configuration. Clients should be able to access the published sites when all servers display a status of Synced.

Or, ask the clients to restart their mobile device or to close all instances of their browsers. This clears the old cookie.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology that Microsoft uses to describe software updates.

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