"5.7.1 smtp;550 5.7.1 RESOLVER.RST.AuthRequired" nondelivery report when external users try to send mail to mail-enabled public folders in Office 365

Applies to: Exchange Online

PROBLEM


When external users try to send email messages to mail-enabled public folders in Office 365, they receive a nondelivery report (NDR) that contains the following error code:
Remote Server returned '<xxxxxxxx> #5.7.1 smtp;550 5.7.1 RESOLVER.RST.AuthRequired; authentication required [Stage: CreateMessage]>'

CAUSE


By default, mail-enabled public folders are prevented from accepting mail from external senders. This behavior is by design and is intended to help protect mail-enabled public folders.

SOLUTION


To change the behavior so that mail-enabled public folders can accept mail from external senders, follow these steps:
  1. Connect to Exchange Online by using remote PowerShell. For more info about how to do this, see Connect to Exchange Online using remote PowerShell.
  2. Add permission for the Anonymous account to public folders. To do this, run the following command:
    Add-PublicFolderClientPermission -identity <Public Folder> -User Anonymous -AccessRights CreateItems 
    For example, run the following command:
    Add-PublicFolderClientPermission –identity “\SpecificFolder” –User Anonymous –AccessRights CreateItems 

MORE INFORMATION


For more information about mail-enabled public folders and Office 365, see Mail-enable or mail-disable a public folder.

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