Request Count data is missing from APM reports after upgrade to Operations Manager 2012 R2

Applies to: System Center 2012 R2 Operations ManagerMicrosoft System Center 2012 Operations Manager Service Pack 1

Symptoms


After you upgrade from System Center 2012 Operations Manager Service Pack 1 (OpsMgr 2012 SP1) to System Center 2012 R2 Operations Manager (OpsMgr 2012 R2), the Request count and Request Time (sec) values are no longer available in Application Performance Monitoring (APM) reports. These values are displayed as 0 (zero) for a while after the upgrade.

Cause


The APM performance counter names for .Net Apps were changed to just Apps in the Operations Manager database. However, there were no corresponding name changes in the Operations Manager Data Warehouse.

Resolution


To resolve this issue, start SQL Server Management Studio, and then connect to the Operations Manager Data Warehouse database. After you're connected, run the following script to update the counter names in the Data Warehouse.

More Information


IMPORTANT: Running this SQL script changes APM reporting so that it will begin to display Request Count data for applications going forward from the point at which the SQL update is run. You will no longer see Request Count data in the APM reports from before the Operations Manager upgrade to System Center 2012 R2. If you want to view data from before the upgrade, run the reports, and then export them before you implement the changes that are described in the "Resolution" section.