Stop error 0x000000D1 after you install the Hyper-V role in Windows Server 2012 R2

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 EssentialsWindows Server 2012 R2 Foundation

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

For information about this same problem in Windows Server 2012, see hotfix 2989586 .

Symptoms


Consider the following scenario:
  • In a Windows Server 2012 R2 based Hyper-V cluster, virtual machine (VM) storage is located on Server Message Block (SMB)-based file shares.
  • You perform a live migration of many VMs from one node to another.

In this scenario, the cluster node crashes during live migration, and you receive the following Stop error message:

0x000000D1 (parameter1 , parameter2 , parameter3 , parameter4 )
DRIVER_IRQL_NOT_LESS_OR_EQUAL


Notes
  • The parameters in this error message vary, depending on the configuration of the computer.
  • Not all "0x000000D1" Stop errors are caused by this problem.


Cause


This problem occurs because of incorrect handling of the IP address structure inside the Vmswitch.sys file.

Resolution


Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update, you must first have update 2919355 installed in Windows Server 2012 R2.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.