TRIM and UNMAP activities for thin provisioning on one volume block all activities on other volumes

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 FoundationWindows Server 2012 R2 Standard More

Symptoms


Consider the following scenario:
  • You use thin provisioning as an end-to-end storage provisioning solution in Windows 8.1, Windows Server 2012 R2, Windows 8 and Windows Server 2012.
  • You have more than one volume in the system.

In this scenario, you discover that I/O performance is affected by the TRIM and UNMAP activities on one volume, and that all activities on the other volumes are blocked.

Cause


This problem occurs because intermittent I/O stalls on thinly provisioned volumes when file-delete notifications are enabled.

Resolution


To resolve this issue, we have released an update rollup for Windows 8.1 and Windows Server 2012 R2, and we have released hotfixes for Windows 8.1, Windows Server 2012 R2, Windows 8 and Windows Server 2012.

Get the update rollup for Windows 8.1 or Windows Server 2012 R2

To resolve this issue, install the update rollup that is dated November 2014.

Get the November 2014 update rollup for Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2

Get the hotfix for Windows 8.1, Windows Server 2012 R2, Windows 8 and Windows Server 2012

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update, you must first have update 2919355 installed in Windows 8.1 and Windows Server 2012 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.