Unexpected display rotation after you close an application in Windows 8.1 or Windows Server 2012 R2

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 StandardWindows Server 2012 R2 Essentials

Symptoms


Consider the following scenario:

  • You have an Intel® Atom™ Processor Z373x series based device that is running Windows 8.1, Windows RT 8.1, or Windows Server 2012 R2.
  • You turn on the device in a native display orientation and rotate the device 90 degrees. Then you encounter one of the following situations: 
    • The device becomes landscape if the native display orientation is portrait.
    • The device becomes portrait if the native display orientation is landscape.
  • You restart the device, and then the device keeps in a non-native display orientation after restarting.
  • You run a Windows Store app or run volume control in desktop.
In this scenario, when you close the application or the volume control, the screen returns to desktop in the native display orientation.

Cause


This issue occurs because the LastAutoRequest registry value in the following registry path is not initialized:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AutoRotation\NonPreserve

How to obtain this hotfix


To resolve this issue, we have released hotfixes for Windows 8.1, Windows RT 8.1, or Windows Server 2012 R2.

Before you install this hotfix, check the prerequisite of the hotfix.

Hotfix for Windows 8.1 or Windows Server 2012 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must first install update 2919355 in Windows 8.1 or Windows Server 2012 R2. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates.



Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.