Application crashes when you input text at the beginning of multiple lines in Windows 8.1 or Windows Server 2012 R2

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 StandardWindows Server 2012 R2 Essentials More

Symptoms


Consider the following scenario:
  • You have a computer that is running Windows 8.1, Windows RT 8.1, or Windows Server 2012 R2.
  • You type more than one line of text in a text control that has the Word Wrap property enabled in an application.
  • You move the cursor to the beginning of the first line, and then you type a character.
In this scenario, the application crashes.

Cause


This issue occurs because of a buffer underflow when the application tries to find the correct position of the cursor.

Resolution


To resolve this issue, we have released a hotfix for Windows 8.1, Windows Server 2012 R2, and we have released an update rollup for Windows 8.1, Windows Server 2012 R2.

Get the update rollup for Windows 8.1 or Windows Server 2012 R2

To resolve this issue, install the November 2014 update rollup for Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2.

Get the hotfix for Windows 8.1 or Windows Server 2012 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have update 2919355 installed in Windows 8.1 or Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


References


See the terminology that Microsoft uses to describe software updates.