"DNS query failed" error when an email message is stuck in the Draft folder in an Exchange Server 2013 environment

Applies to: Exchange Server 2013 EnterpriseExchange Server 2013 Standard EditionExchange Server 2016 Enterprise Edition More

Symptoms


Assume that you have a computer that is a member of a Microsoft Exchange Server 2013 or 2016 environment. You do not have the Register this connection's addresses in DNS check box selected on the DNS tab of the Advanced TCP/IP Settings dialog box of TCP/IPv4. In this situation, email messages remain stuck in the Drafts folder.

Additionally, when you check the transport queue, you see an error message that resembles the following:
4.4.0 DNS query failed. The error was: DNS query failed with error ErrorRetry.

Cause


This issue occurs because the DNS service cannot be used if the Register this connection's addresses in DNS check box is not selected in an Exchange Server 2013 or 2016  environment.

Resolution


To resolve this issue, use one of the following methods.

Method 1: Select the "Register this connection's addresses in DNS" check box

On your computer, select the Register this connection's addresses in DNS check box on the DNS tab of the Advanced TCP/IP Settings dialog box of TCP/IPv4.

Method 2: Enable the DNS service by using a registry key

  1. Select Start, select Run, type regedit in the Open box, and then select OK.
  2. Locate and then select the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters
  3. On the Edit menu, point to New, and then select DWORD (32-bit) Value.
  4. Type EnableDNS, and then press Enter.
  5. In the Details pane, right-click EnableDNS, and then select Modify.
  6. In the Value data box, type 1, and then select ck OK.
  7. Exit Registry Editor.
  8. Restart the Microsoft Exchange Transport service.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.