Non-English language cannot be selected on computer logon page in Server Core installation of Windows Server 2012 R2

Kehtib: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 StandardWindows Server 2012 R2 Essentials

Symptoms


Consider the following scenario:
  • You try to set up a computer that is running a Multilanguage version of Windows Server 2012 R2 in Server Core mode.
  • You select a non-English language when Setup first prompts you to provide a password.
  • After you restart the computer, you are prompted to provide the password to log on to the computer.

In this scenario, the display language is always English, and you cannot select a non-English keyboard. Therefore, you cannot type the previously selected non-English password to log on.

Cause


This problem occurs because the LogonUI.exe process incorrectly changes a registry key.

Resolution


Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update in Windows Server 2012 R2, you must first have update 2919355 installed.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.