How to customize, create, and restore Visio menus in Visio


Summary


This article describes how to create a new menu, customize an existing menu, and restore built-in menus.

More Information


The following items explain how to customize, create, restore, or remove existing menu items.

To Reset All Menus to Their Defaults

  1. On the Tools menu, click Customize.
  2. Click the Toolbars tab.
  3. In the Toolbars list, click Menu Bar. Do not clear the Menu Bar check box.
  4. Click Reset.

    Visio displays the Reset Toolbar dialog box with the following message:
    Are you sure you want to reset the changes made to the 'Menu Bar' toolbar?
  5. Click OK.
  6. Click Close.

To Add a New Menu

  1. On the Tools menu, click Customize.
  2. Click the Commands tab.
  3. In the Categories list, click New Menu.
  4. In the Commands list, click New Menu.
  5. Drag New Menu from the Commands list to the menu bar. Release the mouse button when you see a vertical bar indicating the position of the new menu.
  6. Right-click New Menu on the menu bar, type a name in the Name box, and then press ENTER.
  7. Click Close.
NOTE: To add commands to the menu, follow the steps in the "To Add an Item to a Menu" section of this article.


To Add an Item to a Menu

  1. On the Tools menu, click Customize.
  2. Click the Commands tab.
  3. In the Categories list, select the menu that you want to customize. For example, click File on the menu bar.
  4. In the Commands box, click the command that you want to add to the File menu. For example, click Browse Sample Drawings.
  5. Drag Browse Sample Drawings to the File menu. Release the mouse button when you see a horizontal bar indicating the location on the menu where the command will be inserted.
  6. Click Close.

To Remove an Item from a Menu

  1. On the Tools menu, click Customize.
  2. Click a menu item.
  3. Drag the command that you want to remove into the Customize dialog box and release the mouse button.
  4. Click Close.

To Modify Text or Change a Button Image on a Menu

  1. On the Tools menu, click Customize.
  2. Click a menu item.
  3. Right-click the Menu command.
  4. Choose an action from the drop-down menu.
  5. Click Close.

To Restore a Menu That You Deleted

If no other menu customization exists, you can use the "To Reset All Menus to Their Defaults" section of this article to restore the original menu schema or use the following steps to restore a menu and keep other customization:

  1. On the Tools menu, click Customize.
  2. Click the Commands tab.
  3. In the Categories list, click Built-In Menus.
  4. In the Commands list, click the command that you want to add to the menu bar. For example, if you deleted the View menu, click View.
  5. Drag View from the Commands box to the menu bar. Release the mouse button when you see a vertical bar indicating the position of the menu.
  6. Click Close.

References


For more information about how to customize and create toolbars and toolbar buttons, click the following article number to view the article in the Microsoft Knowledge Base:

305069 How to create custom toolbars and tool buttons in Visio 2002 or in Visio 2003

For more information how to troubleshoot issues related to the menu bar, click the following article number to view the article in the Microsoft Knowledge Base:

305400 Toolbar, toolbar button, or menu bar is missing in Visio 2002