(The WinRM client cannot complete the operation within the time specified) error when you run Hybrid Configuration wizard

Original KB number:   3067913

Symptoms

You want to set up a hybrid deployment between your on-premises Microsoft Exchange Server organization and Exchange Online in Microsoft 365. However, when you run the Hybrid Configuration wizard, the wizard doesn't complete successfully, and you receive a The WinRM client cannot complete the operation within the time specified error message. The full text of this message resembles the following:

ERROR:Updating hybrid configuration failed with error 'Subtask Configure execution failed: Configure Recipient Settings
Execution of the Update-EmailAddressPolicy cmdlet had thrown an exception. This may indicate invalid parameters in your Hybrid Configuration settings.
Processing data from remote server failed with the following error message: The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
at System.Management.Automation.PowerShell.CoreInvoke[TOutput](IEnumerable input, PSDataCollection`1 output, PSInvocationSettings settings
at System.Management.Automation.PowerShell.Invoke(IEnumerable input, PSInvocationSettings settings)
at System.Management.Automation.PowerShell.Invoke()
at Microsoft.Exchange.Management.Hybrid.RemotePowershellSession.RunCommand(String cmdlet, Dictionary`2 parameters, Boolean ignoreNotFoundErrors)

Cause

This issue may occur if a time-out occurs while the following command is running to apply email address policies:

Update-EmailAddressPolicy -Identity 'CN=Default Policy,CN=Recipient Policies,CN=<Exchange Org>,
CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DN of Org>

In large organizations, this command may experience a time-out if there are significant changes to email address policies.

Resolution

To resolve this issue, follow these steps:

  1. Open the Exchange Management Shell, and then run the following command:

    Update-EmailAddressPolicy -Identity 'CN=Default Policy,CN=Recipient Policies,CN=<Exchange Org>,
    CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DN of Org>
    
  2. Rerun the Hybrid Configuration wizard.

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