"The WinRM client cannot complete the operation within the time specified" error message when you run the Hybrid Configuration wizard

Прилага се за: Exchange OnlineExchange Server 2013 EnterpriseExchange Server 2013 Standard Edition

PROBLEM


You want to set up a hybrid deployment between your on-premises Microsoft Exchange Server organization and Exchange Online in Microsoft Office 365. However, when you run the Hybrid Configuration wizard, the wizard doesn't complete successfully, and you receive a "The WinRM client cannot complete the operation within the time specified" error message. The full text of this message resembles the following:
ERROR:Updating hybrid configuration failed with error 'Subtask Configure execution failed: Configure Recipient Settings
Execution of the Update-EmailAddressPolicy cmdlet had thrown an exception. This may indicate invalid parameters in your Hybrid Configuration settings. 
Processing data from remote server failed with the following error message: The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
   at System.Management.Automation.PowerShell.CoreInvoke[TOutput](IEnumerable input, PSDataCollection`1 output, PSInvocationSettings settings
   at System.Management.Automation.PowerShell.Invoke(IEnumerable input, PSInvocationSettings settings)
   at System.Management.Automation.PowerShell.Invoke()
   at Microsoft.Exchange.Management.Hybrid.RemotePowershellSession.RunCommand(String cmdlet, Dictionary`2 parameters, Boolean ignoreNotFoundErrors)

CAUSE


This issue may occur if a time-out occurs while the following command is running to apply email address policies:
Update-EmailAddressPolicy -Identity 'CN=Default Policy,CN=Recipient Policies,CN=<Exchange Org>,
CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DN of Org>
In large organizations, this command may experience a time-out if there are significant changes to email address policies. 

SOLUTION


To resolve this issue, follow these steps:
  1. Open the Exchange Management Shell, and then run the following command:
    Update-EmailAddressPolicy -Identity 'CN=Default Policy,CN=Recipient Policies,CN=<Exchange Org>,
    CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DN of Org>
  2. Rerun the Hybrid Configuration wizard.
 

MORE INFORMATION


If you experience issues with the Hybrid Configuration wizard, you can run the Exchange Hybrid Configuration Diagnostic. This diagnostic is an automated troubleshooting experience. Run it on the same server on which the Hybrid Configuration wizard failed. Doing this collects the Hybrid Configuration wizard logs and parses them for you. If you're experiencing a known issue, a message is displayed that tells you what went wrong. The message includes a link to an article that contains the solution. Currently, the diagnostic is supported only in Internet Explorer.

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