Active Directory contact's name is changed to the phone number in the contact list of Skype for Business or Lync 2013

Applies to: Lync Server 2013Skype for Business

This issue occurs when a contact has no email or session initiation protocol (SIP) address and only has a display name and a phone number in Active Directory Domain Services.

Cause


This issue occurs because the contact is not matched based on the phone number. It is only matched based on the SIP or simple mail transfer protocol (SMTP) address in Microsoft Lync 2013 (Microsoft Skype for Business).

Resolution


To resolve this issue, install the July 14, 2015 update (KB3054946) for Lync 2013 (Skype for Business).

Note Lync 2013 was upgraded to Skype for Business in April 2015.