"Unsupported version of Microsoft Exchange" error when you use Outlook 2016 to connect an Exchange 2007 account

Symptoms

When you try to connect to an account on a Microsoft Exchange 2007 server, you receive the following error message: 
The resource that you are trying to use is located on an unsupported version of Microsoft Exchange.

Workaround

To work around this issue, you can revert to Outlook 2013 or an earlier version, or you can upgrade Exchange Server to Exchange 2010 or a later version. Outlook 2016 doesn't support connecting to Exchange 2007 because Outlook 2016 requires features that are unavailable in Exchange 2007.

More Information

If you were auto-upgraded to Office 2016 from Office 365 Personal, Office 365 Home, or Office 365 University, and you want help in reverting to the earlier version, contact Microsoft support by selecting Contact Answer Desk on the Microsoft support page.
Properties

Article ID: 3093039 - Last Review: Sep 23, 2015 - Revision: 1

Feedback