Revolution R Error message when launching IDE

Problem

When I launch Revolution R v. 7.4, it hangs and returns the following error message:

Package Load Failure. Package "REvolutionComputing.RHelpIndex.RHelpIndex Package, RHelpIndex, Version=1.0.0.0, 
Culture=neutral, PublicKeyToken=null has failed to load properly (GUID={5B4300IF-B9BD-4326-A87F-821D89EBC626}). Please contact package vendor for assistance.

If I uninstall 7.1 and then reinstall it, it works normally until I re-start my workstation, when I obtain the same error message.

Solution

1.  Open a command prompt and go to the location Revolution R Enterprise is installed.  By default  C:\Program Files\Revolution\R-Enterprise-7.4\IDE64 

2.  Type the command RevoIDE.exe /resetskippkgs and press enter.

Restart Revolution R.  The issue should be fixed in most cases.  Should it persist do the following:

1). Open a DOS window as Administrator via 'Start ---> All Programs --> Accessories' and right-clicking on 'Command Prompt'.

2). In the DOS window 'cd' to the directory 'C:\Program Files\Revolution\R-Enterprise-7.4\IDE64'.

3). Exit any currently running session of Revolution R, then run the following commands to reset graphical settings(from the DOS window):

start /wait Revoide.exe /remove
start /wait Revoide.exe /setup
(this last line will take about 30 seconds to complete)

4). Restart the application - things should be back to normal again.

If things are not back to normal you will need to uninstall and reinstall the program via the 'Programs and Features' menu in Windows.

If you need to unistall the program, you should make sure to also delete the folder 'C:\Program Files\Revolution\R-Enterprise-7.4' before reinstalling the software.
Properties

Article ID: 3104093 - Last Review: Oct 29, 2015 - Revision: 1

Revolution Analytics

Feedback