"Unable to load native-hadoop library" warning in mapreduce output when running RevoScaleR job

When running a RevoScaleR job in Hadoop, the mapreduce console output may contain the message:WARN util.NativeCodeLoader:
Unable to load native-hadoop library for your platform... using builtin-java classes where applicable.

This warning is unrelated to RevoScaleR operation. It is usually a result of running in a 64-bit Linux environment while the 
$HADOOP_HOME/lib/native/libhadoop.so
 was compiled in a 32-bit environment. The warning is harmless and can be ignored.
Properties

Article ID: 3104118 - Last Review: Oct 31, 2015 - Revision: 1

Revolution Analytics

Feedback