Applications may freeze when ADSI APIs waits infinitely for server to respond in Windows Server 2012 R2

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 StandardWindows Server 2012 R2 Essentials More

This article describes an issue that occurs when applications use Active Directory Service Interfaces (ADSI) APIs in Windows Server 2012 R2. A hotfix is available to fix this issue. The hotfix has a prerequisite.

Cause


This issue occurs because ADSI doesn't support time-outs when LDAP calls are made to domain controllers. Instead, a NULL value is passed in most of the API calls. This causes Wldap32.dll to wait until a response is received from the server.

Affected applications

The following applications are reported to have encountered this issue:

Resolution


To fix this issue, we have released a hotfix. Even though this issue is observed in Windows Server 2012 R2 only, this hotfix also applies to Windows 8.1 and Windows RT 8.1.

Important If you install a language pack after you install this hotfix, you must reinstall this hotfix. Therefore, we recommend that you install any language packs that you need before you install this hotfix. For more information, see Add language packs to Windows.

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that's described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there's a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section doesn't appear, submit a request to Microsoft Customer Service and Support to get the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that don't qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you don't see your language, it's because a hotfix isn't available for that language.

Prerequisites

To apply this hotfix, you must have April 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 (2919355) installed in Windows 8.1 or Windows Server 2012 R2.

Registry information

This hotfix introduces a default time-out at the ADSI (Active Directory Service Interfaces) level, it may cause application compatibility issues in which a legitimate LDAP query takes more than 10 minutes to respond in some rare scenarios. After you install this hotfix, all such LDAP queries will time out. Therefore, there is a registry switch to disable or enable the default time-out.

Registry key path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ADSI\Tracing
Registry key name: DisableAdsiTimeout
Type: REG_DWORD

Notes:

  • If the registry key is not present, global time-out is set to default of 10 minutes.
  • If the registry key is present with a value (0), global time-out is set to default 10 minutes.
  • If the registry key is present with a non-zero value, global time-out is disabled and it reverts to the previous behavior (there is no timeout and it is timeout indefinite).

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix doesn't replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.

File Information


The English (United States) version of this software update installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). Be aware that dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time bias. The dates and times may also change when you perform certain operations on the files.